Notating Drum & Perc. Parts in Sibelius

Katie Wardrobe
Midnight Music
Drum parts from Scratch #1: Using the Computer Keyboard .............................................. 4
  Working with voices ........................................................................................................... 4
  Enter the hi-hat part (voice 1)............................................................................................ 4
  Changing noteheads ........................................................................................................... 5
  Add the snare part (voice 1) ............................................................................................... 5
  Bass drum part (voice 2) .................................................................................................... 5

From scratch #2: manual input using the MIDI keyboard ................................................. 6
  Set-up .................................................................................................................................... 6
  Hi-Hat and Snare parts ........................................................................................................ 6
  Bass drum .............................................................................................................................. 6

From scratch #3: recording the drum part “live” ............................................................... 7
  Set-up part 1 ....................................................................................................................... 7
  Set-up part 2 ....................................................................................................................... 7
  Recording the drum part .................................................................................................... 7

Copy and Paste .................................................................................................................... 8

Repeat Bar Signs .................................................................................................................. 8

Open and closed signs ........................................................................................................... 8
  Open sign ............................................................................................................................. 8
  Closed sign ........................................................................................................................ 8

Ghost Stroke Noteheads ..................................................................................................... 8

Sticking .................................................................................................................................. 9
  Adding sticking into your score .......................................................................................... 9

Rolls ....................................................................................................................................... 9

Grace Notes (Flams and drags) ............................................................................................ 9
  Grace note ........................................................................................................................... 9
  Drag (looks like two semiquavers joined together) .............................................................. 10
  Adding a slur ..................................................................................................................... 10

Slash notation ...................................................................................................................... 10
  Add text indication (“Play time” or “Fill” or “Solo”) .......................................................... 10

Rhythmic Notation (slashes with stems) ........................................................................ 10

Numbering Bars Automatically ......................................................................................... 11

Layout ................................................................................................................................... 11

Two other quick ways to create drum parts ................................................................. 12
Music technology training
Free monthly email newsletter
www.midnightmusic.com.au

Use the Ideas window (Sibelius 5 and 6 only) ................................................................. 12
Use the Add Drum Pattern Plug-in .................................................................................. 12

Orchestral Parts: Multiple instruments, one player ......................................................... 12
  Using separate staves ...................................................................................................... 12
  Basic formatting .............................................................................................................. 12
  Using instrument changes ............................................................................................. 13

Resources .......................................................................................................................... 13
  Book: Guide To Standardized Drumset Notation by Norman Weinberg ..................... 13
  Tutorial Videos ............................................................................................................... 13
  Sibelius Reference manual ......................................................................................... 13
  Sibelius Drum map and GM Percussion map ............................................................... 13

Contact me (I’m happy to answer questions 😊) .............................................................. 14
Drum parts from Scratch #1: Using the Computer Keyboard

When creating drum kit patterns you only need to notate one or two bars because you can copy and paste the pattern for the remainder of the score, or use a “repeat bar” sign.

Working with voices
Because we’ll need to notate two rhythmically independent parts, we need to use two voices on the one stave.

• **Voice 1** (blue) has stems pointing up
• **Voice 2** (green) stems pointing down

In drum kit notation:
• Use voice 1 use for parts of the kit played with hands (cymbals, snare)
• Use voice 2 for parts played with the feet (bass drum, hi-hat foot pedal)
• **Exception:** when the rhythm is more clear notated in a different way (see the accompany notes: Notation Conventions)

Enter the hi-hat part (voice 1)
• Select bar one (it should have a blue box around it)
• Press **N** (for note entry)
• Enter the rhythm for hi-hat part (quavers in the space on top of the stave)

• Don’t worry that the stems are pointing down – they’ll move up automatically when we add the bass drum part
• And don’t worry about the fact that there was no sound when you entered the notes. In order for the snare drum part to make a sound, we need to change the noteheads to crosses

Changing noteheads
• Press Escape twice to make sure you have nothing selected
• Now select the whole bar again

Add the snare part (voice 1)
• Select the 3rd hi-hat quaver and type Shift+5 to add a note a 5th below for the snare drum part

• While it is still selected, change it back to a normal notehead by selecting notehead 0 from the noteheads drop-down menu (in the Properties window)

• Add a snare drum note to the 7th quaver (beat 4) and change the notehead back to a normal notehead, as you did before
• Press Escape

Bass drum part (voice 2)
• Select bar one again
• Press N for note entry
• Switch to voice 2: by pressing Alt+2 (Opt+2 on Mac)
• Enter the bass drum rhythm. You’ll notice that the stems of the voice 1 part (hi-hat and snare) jump up automatically when the first bass drum note is entered
• Press Escape
From scratch #2: manual input using the MIDI keyboard

Instead of using your computer keyboard to enter notes on the drum kit stave, you can speed things up by using a MIDI keyboard. It’s quicker with a MIDI keyboard because the noteheads are automatically entered in the correct way (ie. snare drum parts will automatically have cross-noteheads).

Set-up

- Go to File > Preferences (or Sibelius > Preferences on Mac) and select Note Input from the menu on the left
- Under Percussion Staves, select The MIDI device’s drum map. This means you’ll be using the inbuilt MIDI percussion instruments in your keyboard to enter notes on the drum kit stave

Hi-Hat and Snare parts

- Select bar one
- Press N (for note entry)
- Select quaver on the Keypad
- Play the F sharp below the bass clef (F#2) on keyboard to create the hi-hat notes. When you reach beat 2 and 4, F#2 and D2 at the same time to create the hi-hat and snare simultaneously
- Press Escape twice to finish

Bass drum

- Select the bar again
- Press N and then press Alt+2 (Opt+2) to enter notes into voice 2
- Enter the bass drum pattern using C2 on your MIDI keyboard
From scratch #3: recording the drum part “live”

Even quicker still, is recording the entire drum kit part in all at once using Sibelius’s Flexi-time input method.

Set-up part 1

• Go to File > Preferences (or Sibelius > Preferences on Mac) and select Note Input from the menu on the left
• Under Percussion Staves, select The MIDI device’s drum map. This means you’ll be using the inbuilt MIDI percussion instruments in your keyboard to enter notes on the drum kit stave

Set-up part 2

• Go to Notes > Flexi-time options
• On the Flexi-time tab, check the Record into multiple voices box
• On the Notation tab, choose the minimum rhythmic value you will play under Adjust Rhythms

Recording the drum part

• Select the bar where you want to start recording the drum part
• Click on the Record button (on the Playback window), or use the shortcut Ctrl+Shift+F (Cmd+Shift+F on Mac)
• Play the drum pattern, using the MIDI drum map (ie. C2 for the bass drum, F#2 for the hi-hat etc)
Copy and Paste

You can copy and paste a pattern by using one of the following methods:

- Select the bar and press R (for repeat)
- Select the bar and then hold down Alt (Opt) and click at the beginning of a bar

Repeat Bar Signs

Indicate the pattern is repeated by using the repeat bar sign

- Select the bar after the initial drum pattern appears
- Go to the 5th Keypad layout
- Click on the appropriate repeat bar sign (or press number 1, 2 or 4 on your computer’s numeric keypad)

Open and closed signs

Open sign

- To add an open sign (o) to a note, select the note and then choose o from the 4th keypad layout

Closed sign

- To add an closed sign (+) to a note, select the note and then choose + from the 4th keypad layout
- Using the closed and open signs will be reflected in the playback of your score

Ghost Stroke Noteheads

A ghost stroke is a note with parentheses on either side of the notehead and it’s played at an extremely soft dynamic.

- Select the notehead
- Go to the 2nd keypad layout
- Press number 1 on your computer’s numeric keypad, or click on the parentheses with the mouse
Sticking

Sticking is indicated by an uppercase R and L and denotes which hand should be used to play each note of a rhythm. Sticking can appear below the stave, or above the stave.

**Adding sticking into your score**

- Select the first note of the pattern
- For sticking that appears below the stave, **Create > Text > Lyrics**
- For sticking that appears above the stave, go to **Create > Text > Lyrics > Lyrics above the staff**
- Type R or L and then press **space** to advance to the next note
- When you’ve finished, press **Escape**

Rolls

- Select the note/s
- Go to the 3rd Keypad layout and choose one of the tremolo options

Grace Notes (Flams and drags)

A grace note (such as a flam or a drag) is struck just ahead of the main note. The stem always points up and there should be a slur from the grace note/s to the main note.

**Grace note**

- Go to the 2nd keypad layout
- Click on the grace note (acciaccatura) and click in the score, just before the main note
Drag (looks like two semiquavers joined together):
• Choose semiquaver from the first keypad layout
• Then choose the grace note (appoggiatura) from the 2nd keypad layout
• Click the two notes into the score, just before the main note

Adding a slur
• Select the grace note and press S
• Press space bar to extend the slur if necessary

Slash notation
Slash notation indicates that a player should improvise a part in the appropriate style. There’s usually a written instruction included to indicate whether the drummer should “play time” (a timekeeping pattern), or a fill or a solo.

• Create 4 crotchets on the middle line of the stave
• Select the bar
• Go to Window > Properties and click on the Noteheads tab
• Select Notehead 3 from the drop-down menu

Add text indication (“Play time” or “Fill” or “Solo”)
• Select the first note in the bar
• Press Ctrl+T (Cmd+T), or go to Create > Text > Technique
• A flashing cursor will appear and you can type the text you need

Rhythmic Notation (slashes with stems)
Rhythmic notation specifies the rhythm the drummer should play, but allows them to improvise the instrumentation.

• Enter the rhythm on middle line of drum set stave
• Select the bar/s
• Go to Window > Properties and click on the Noteheads tab
• Select Notehead 4 from the drop-down menu
**Numbering Bars Automatically**

- Select the bars
- Go to Plugins > Text > Number Bars
- Choose the appropriate settings
- Click OK

**Layout**

I don’t often recommend laying out your score with a uniform number of bars per line, but for jazz/pop it is a fairly standard layout choice and can be very useful due to the nature of the music. Most jazz/pop songs are grouped in bars of 4/8/16 and having a uniform 4 bars across a line makes it easy for a drummer to keep track of the part.

- Go to Layout > Auto Breaks
- Under System Breaks in the top left hand corner, choose Use auto system breaks and click on the Every n bars button
- Fill in the appropriate number in the box and click OK
Two other quick ways to create drum parts

**Use the Ideas window (Sibelius 5 and 6 only)**

- Go to Window > Ideas
- Click on the Library tab
- Search for drum parts using the search field at the top – eg. type in “Jazz drums”
- Click and hold the mouse button on an Idea to hear it

When you find one you like, copy and paste it into your score:

- Select it in the Ideas window
- Press Ctrl+C (Cmd+C)
- Select the destination bar in your score
- Press Ctrl+V (Cmd+V)

**Use the Add Drum Pattern Plug-in**

- Go to Plug-ins > Composing Tools > Add Drum Pattern
- Choose a style from the drop-down menu
- Click OK. The drum part will be added to your score

---

**Orchestral Parts: Multiple instruments, one player**

There are two basic ways to set up an orchestral part that uses multiple instruments and only one player:

**Using separate staves**

Use a separate stave for each instrument being played, draw them together in one part and hide the instruments that are not playing.

Create a part that includes the percussion staves you need:

- go to Window > Parts and click on the New Part button
- Select the instruments you need down the left side and click Add to Part
- Click OK
- The new part you created will appear in the Parts Window. You can rename it by clicking on its title

**Basic formatting**

- Open the new part
- Hide the instrument/s that are not playing: select the entire score (or a portion of it) and go to Layout > Hide Empty Staves
- Ensure that multirests are turned on (go to Layout > Auto Breaks and check the Use Multirests box)
• Add in System breaks at end of the line to create a clean switch if necessary
• Can sometimes leave two staves showing at once – player can read both simultaneously

Using instrument changes
Use one single stave for all instruments. Create an Instrument Change when the player needs to switch to a new instrument. This method can be less effective if there are frequent changes in staff type (eg. From a single line to 5 lines), but it works well when all instruments use same staff type.

When the percussion player needs to switch to a new instrument:
• Go to Create > Other > Instrument Change
• Find the new instrument in the window that opens and click OK
• Click in the score where the new instrument starts
• The playback sound will change and some text will be added to your score to indicate to the player that they should change instruments

Resources

Book: Guide To Standardized Drumset Notation by Norman Weinberg
• Published by the Percussive Arts Society
• Distributed by Hal Leonard (06620063)

Tutorial Videos
• I’ve made 3 tutorial videos about creating drum parts in Sibelius that can be found on Youtube: www.youtube.com/katiesw1

Sibelius Reference manual
• See the Percussion section
• The Drum Set and Drum Kit staves in Sibelius use the drum map which is pictured in this section
• The drum map tells you which line/space to use on the stave and also which notehead to use for each of the drum set instruments

Sibelius Drum map and GM Percussion map
• Book: Sibelius - A Comprehensive Guide to Sibelius Music Notation Software (Rudolph/Leonard)
• This book has a companion website: www.sibeliusbook.com which has a useful set of Chapter File/Downloads. The Chapter 8 files include a pdf of the Sibelius drum map and also the GM percussion map (for entering notes via MIDI keyboard)
Contact me (I’m happy to answer questions 😊)

Contact me regarding

- training enquiries or presentations for your school/network/event
- music technology-related questions

Email: katie@midnightmusic.com.au
Mobile: 0412 403 704
Website: www.midnightmusic.com.au
Facebook: www.facebook.com/midnightmusic
Twitter: www.twitter.com/katiesw1