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Basic drum kit parts in Sibelius

Introduction

3 ways to enter drum parts from scratch

There are 3 ways to enter drum parts from scratch in Sibelius:

• manual input using the computer keyboard

• manual input using a MIDI keyboard

• recording the drum part “live” using a MIDI keyboard

The !rst method is slow and tedious because you need to manually change noteheads as you go.  The 
second and third method, which involve using a MIDI keyboard, are much quicker.  

If you are going to spend time creating drum parts, I can highly recommend purchasing a MIDI keyboard 
- even a small inexpensive one - to make life easier.

An explanation of each method is given below.

Manual input using the computer keyboard

When creating drum kit patterns you often only need to notate one or two bars because you can copy 
and paste the pattern for the remainder of the score.

Because we’ll need to notate two rhythmically independent parts, we need to use two voices on one stave 
in Sibelius.

• Voice 1 (blue) has stems pointing up

• Voice 2 (green) stems pointing down

Using voices in drum kit notation

• Use voice 1 use for parts of the kit played with hands (ie. cymbals and snare)
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• Use voice 2 for parts played with the feet (bass drum, hi-hat foot pedal)

The complete pattern:

Exceptions

Not all drum patterns should be notated this way, but it’s a good general rule to go by.  An exception to 
this rule is when the snare works rhythmically with the kick drum, as in the following example:

In the above example, the snare is notated in Voice 2, with the kick drum, whilst the hi-hat is in voice 1.

Entering the hi-hat part: voice 1

• Select bar one (it should have a blue box around it)

• Press N (for note entry)

• Enter the rhythm for hi-hat part (quavers in the space on top of the stave)

• Don’t worry that the stems are pointing down – they’ll move up automatically when we add the 
kick drum part

• And don’t worry about the fact that there was no sound when you entered the notes.  In order for 
the snare drum part to make a sound, we need to change the noteheads to crosses

Changing the noteheads

• Press Escape twice to make sure you have nothing selected 
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• Now select bar one again

• Sibelius 5 & 6:

✦ Go to Window > Properties and click on the Notes tab

✦ From the noteheads drop-down menu, select notehead number 1 
(cross) 

✦ Press Escape 

✦ You can also use the shortcut Alt+Shift+1 (Opt+Shift+1 on Mac)

• Sibelius 7: 

✦ Go to Notations > Noteheads and click on the lower half of the 
Type button

✦ Select the Cross notehead (notehead number 1)

✦ Press Escape

✦ You can also use the shortcut Alt+Shift+1 (Opt+Shift+1 on Mac)

 

Add the snare part

• Select the 3rd hi-hat quaver and type Shift+5 to add a note a 5th below for the snare drum part

• While that note is still selected, change it back to a normal notehead by selecting notehead 0 by 
using the shortcut Alt+Shift+0 (Opt+Shift+0 on Mac) 

• Add another snare drum note to the 7th quaver (beat 4) and change the notehead back to a 
normal notehead, as you did before

• Press Escape

Enter the bass drum (kick) part: voice 2

• Select bar one again
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• Press N for note entry

• Switch to voice 2 by clicking on the Voice 2 button on the Keypad (see right), or by 
pressing Alt+2 (Opt+2 on Mac)

• Enter the bass drum rhythm.  You’ll notice that the stems of the voice 1 part (hi-
hat and snare) jump up automatically when the !rst bass drum note is entered

• Press Escape

That’s all – the pattern is complete.  You can now copy and paste the pattern into the other bars of the 
drum part.

Manual input using the MIDI keyboard

Instead of using your computer keyboard to enter notes on the drum kit stave, you can speed things up 
by using a MIDI keyboard.  It’s quicker with a MIDI keyboard because the noteheads are automatically 
entered in the correct way (ie. hi-hat part will automatically have cross-noteheads).

Set-up: before you start

• Go to File > Preferences (Sibelius 7 and PC users of Sibelius 6 and earlier) or Sibelius > 
Preferences on Mac (Sibelius 6 and earlier)

•  Select Note Input from the menu on the left

• Under Percussion Staves, select The MIDI device’s drum map.  This means you’ll be using the 
inbuilt MIDI percussion instruments in your keyboard to enter notes on the drum kit stave

Enter the hi-hat and snare parts

• Select bar one

• Press N (for note entry)
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• Select quaver on the Keypad

• Play the F sharp below the bass clef (F#2) on keyboard to create the hi-hat notes.  When you reach 
beat 2 and 4, play F#2 and D2 at the same time to create the hi-hat and snare simultaneously

• Press Escape twice to !nish

Bass (kick) drum part

• Select the bar again

• Press N and then press Alt+2 (Opt+2) to enter notes into voice 2

• Enter the bass drum part by using C2 on your MIDI keyboard

Recording the drum part “live” with a MIDI keyboard

Even quicker still, is recording the entire drum kit part in all at once using Sibelius’s Flexi-time input 
method.

Set-up part #1

• Go to File > Preferences (Sibelius 7 and PC users of Sibelius 6 and earlier) or Sibelius > 
Preferences on Mac (Sibelius 6 and earlier)

• Select Note Input from the menu on the left

• Under Percussion Staves, select The MIDI device’s drum map (see image below).  This means 
you’ll be using the inbuilt MIDI percussion instruments in your keyboard to enter notes on the 
drum kit stave

Set-up part #2

Open Flexi-time Options:

• Sibelius 5 & 6: go to Notes > Flexi-time options

• Sibelius 7: go to Note input > Flexi-time and click on the Flexi-time 
options dialogue launcher button (see image right)
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• Then, on the Flexi-time tab check the Record into 
multiple voices option (see image, right)

• On the Notation tab, choose the minimum 
rhythmic value you will play under Adjust 
Rhythms (see image, right)

Recording the drum pattern

• Select the bar or rest where you want to start recording the drum part

• Click the Record button (on the Playback window), 
or use the shortcut Ctrl+Shift+F (Cmd+Shift+F on 
Mac)

• Play the drum pattern on your keyboard, using the 
MIDI drum map (ie. C2 for the kick drum, F#2 for the hi-hat and D2 for the snare)

Copying patterns and repeat bar signs

Copy and paste

You can copy and paste a notated pattern by using one 
of the following methods:

• Select the bar and press R (for repeat)

• Select the bar and then hold down Alt (Opt on Mac) and click at the beginning of a bar
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Repeat Bar Signs

Drum patterns are much easier to read if you make use of the repeat bar sign.  It looks a little like a 
division sign and at a glance, the drummer can see that they should repeat the pattern in the previous 
bar.

To add the repeat bar sign in Sibelius 6 and 7, do the following:

• Select the bar after the initial drum pattern appears

• Go to the 5th Keypad layout

• Click on the appropriate repeat bar sign (or press number 1, 2 or 4 on your 
computer’s numeric keypad)

• You can also use the 2-bar repeat sign or 4-bar repeat sign

Open and closed signs

Open sign

• To add an open sign (o) to a note, select the note and then choose o from the 
4th keypad layout

Closed sign

• To add an closed sign (+) to a note, select the note and then choose + from the 4th 
keypad layout

• Using the closed and open signs will be re"ected in the playback of your score
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Ghost Stroke Noteheads

A ghost stroke is a note with parentheses on either side of the notehead and it’s played at 
an extremely soft dynamic.  

• Select the notehead

• Go to the 2nd keypad layout

• Press number 1 on your computer’s numeric keypad, or click on the parentheses with 
the mouse

Sticking
Sticking is indicated by an uppercase R and L and denotes which hand should be used to play each note 
of a rhythm.  Sticking can appear below the stave, or above the stave.

Sticking below the stave

• Select the !rst note of the pattern

• Sibelius 5 & 6: go to Create > Text > Lyrics or 
use the shortcut Ctrl+L (Cmd+L on Mac)

• Sibelius 7: go to Text > Lyrics and click on the 
Lyrics button or use the shortcut Ctrl+L (Cmd+L on Mac)

• Type R or L and then press space to advance to the next note

• When you’ve !nished, press Escape

Sticking above the stave

• Select the !rst note of the pattern

• Sibelius 5 & 6: go to Create > Text > Lyrics > Lyrics above the staff

• Sibelius 7: go to Text > Lyrics and click on the lower half of the Lyrics button.  
Choose Lyrics above staff (see image, right)

• Type R or L and then press space to advance to the next note

• When you’ve !nished, press Escape
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Rolls

• Select the note/s

• Go to the 3rd Keypad layout and choose one of the tremolo options

Grace Notes (Flams and drags)

A grace note (such as a "am or a drag) is struck just ahead of the main note.  The stem always points up 
and there should be a slur from the grace note/s to the main note.

How to enter a grace note

• Go to the 2nd keypad layout 

• Click on the grace note (acciaccatura) and click in the score, just before the main 
note

How to notate a drag 

A drag looks like two semiquavers joined together (see 3rd example above) 

• Choose semiquaver from the !rst keypad layout

• Then choose the grace note (appoggiatura) from the 2nd keypad layout

• Click the two notes into the score, just before the main note

How to add a slur

• Select the grace note and press S

• Press space bar to extend the slur if necessary

Slash notation

Slash notation indicates that a player should improvise a part in the appropriate style.  There’s usually a 
written instruction included to indicate whether the drummer should “play time” (a timekeeping pattern), 
or a !ll or a solo.
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How to create slash notation

• Create 4 crotchets on the middle line of the stave

• Select the entire bar

• Sibelius 5 & 6:

✦ Go to Window > Properties and click on the Notes tab

✦ From the noteheads drop-down menu, select notehead number 3  

✦ Press Escape 

✦ You can also use the shortcut Alt+Shift+3 (Opt+Shift+3 on Mac)

• Sibelius 7: 

✦ Go to Notations > Noteheads and click on the lower half 
of the Type button

✦ Select the Beat without stem notehead (notehead 
number 3)

✦ Press Escape

✦ You can also use the shortcut Alt+Shift+3 (Opt+Shift+3 on Mac)

How to add a text indication (“Play time” or “Fill” or “Solo”) 

• Select the !rst note in the bar

• Press Ctrl+T (Cmd+T on Mac)

• A "ashing cursor will appear and you can type the text you need

Rhythmic Notation (slashes with stems)

Rhythmic notation speci!es the rhythm the drummer should play, but allows them to improvise the 
instrumentation.

How to create rhythmic slash notation

• Enter the rhythm on middle line of drum set stave 

• Select the bar/s 

• Sibelius 5 & 6:
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✦ Go to Window > Properties and click on the Notes tab

✦ From the noteheads drop-down menu, select notehead number 4  

✦ Press Escape 

✦ You can also use the shortcut Alt+Shift+4 (Opt+Shift+4 on Mac)

• Sibelius 7: 

✦ Go to Notations > Noteheads and click on the lower half of the Type button

✦ Select the Beat with stem notehead (notehead number 4)

✦ Press Escape

✦ You can also use the shortcut Alt+Shift+4 (Opt+Shift+4 on Mac)

Numbering Bars Automatically

How to number bars

• Select the bar/s

• Sibelius 5 & 6: go to Plugins > Text > Number Bars

• Sibelius 7: go to Text > Plugins > Number Bars

• In the window that opens, choose the appropriate settings 

• Click OK
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Layout

I don’t often recommend laying out a score with a uniform number of bars per line, but for jazz/pop 
music it is a fairly standard layout choice.  Many drummers !nd it helpful because most jazz/pop music is 
made up of groups of 4, 8 or 16 bars.  Having a uniform 4 bars across a line makes it easy for a drummer to 
keep track of the part. 

How to layout a score with 4 bars per system

• Sibelius	  5	  &	  6:	  go to Layout > Auto Breaks

• Sibelius	  7:	  go to Layout > Breaks > Auto Breaks

• Under System Breaks in the top left hand corner, choose Use 
auto system breaks and click on the Every n bars button

• Fill in the appropriate number in the box and click OK

Two other quick ways to create drum parts

Method 1: use the Ideas window (Sibelius 5, 6 and 7)

• Sibelius 5 & 6: go to Window > Ideas

• Sibelius 7: go to View > Panels > Ideas

• Click on the Library tab 

• Search for drum parts using the search !eld at the top – eg. type 
in “Jazz drums”

• Click and hold the mouse button on an Idea to hear it

When you !nd one you like, copy and paste it into your score

• Select the idea in the Ideas window

• Select the destination bar in your score

• Click on the Paste Idea button

Method	  2: use the “Add Drum Pattern” plug-in

• Sibelius 5 & 6: go to Plug-ins > Composing Tools > Add Drum Pattern

• Sibelius 7: go to Note Input > Plug-ins and under Composing Tools, choose Add Drum Pattern

• Choose a style from the drop-down menu

• Click OK.  The drum part will be added to your score
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Orchestral Parts: Multiple instruments, one player

There are two basic ways to set up an orchestral part that uses multiple instruments and only one player: 

Method 1: using separate staves

Use a separate stave for each instrument being played, draw them together in one part and hide the 
instruments that are not playing.  

Create a part that includes the percussion staves you need:

• Sibelius 5 & 6: go to Window > Parts and click on the New Part button

• Sibelius 7: go to Parts > Setup > New Part

• Select the instruments you need down the left side and click Add to Part

• Click OK

• The new part you created will appear in the Parts Window.  You can rename it by clicking on its title 

Basic formatting

• Open the new part

• Hide the instrument/s that are not playing:

✦ Sibelius 5 & 6:  select the entire score (or a portion of it) and go to Layout > Hide Empty Staves 

✦ Sibelius 7: select the entire score (or a portion of it) and go to Layout > Hiding Staves > Hide 
Empty Staves 

• Ensure that multirests are turned on:

✦ Sibelius 5 & 6: go to Layout > Auto Breaks and check the Use Multirests box

✦ Sibelius 7: go to Layout > Breaks > Auto Breaks and check the Use Multirests box

• Add in System breaks at end of systems to create a clean switch if necessary (select the barline and 
press Enter/Return)

• You can sometimes have two staves showing at once – the player can read both simultaneously

Method 2: using the Instrument Change feature

Use one single stave for all instruments.  Create an Instrument Change when the player needs to switch 
to a new instrument.  This method can be less effective if there are frequent changes in staff type (eg. 
From a single line to 5 lines), but it works well when all instruments use same staff type. 

When the percussion player needs to switch to a new instrument:

• Sibelius 5 & 6: go to Create > Other > Instrument Change

• Sibelius 7: go to Home > Instruments > Change

• Find the new instrument in the window that opens and click OK
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• Click in the score where the new instrument starts

• The playback sound will change and some text will be added to your score to indicate to the player 
that they should change instruments

Other Resources

Book: Guide To Standardized Drumset Notation by Norman Weinberg 

• Published by the Percussive Arts Society

• Distributed by Hal Leonard (06620063)

Tutorial Videos

• I’ve made 3 tutorial videos about creating drum parts in Sibelius that can be found on Youtube: 
www.youtube.com/katiesw1  

Sibelius Reference manual

• See the Percussion section  

• The Drum Set and Drum Kit staves in Sibelius use the drum map which is pictured in this section 
of the manual

• The drum map tells you which line/space to use on the stave and also which notehead to use for 
each of the drum set instruments

Sibelius Drum map and GM Percussion map

• The book: Sibelius - A Comprehensive Guide to Sibelius Music Notation Software (Rudolph/Leonard) 
has a companion website: www.sibeliusbook.com which has a useful set of Chapter File/
Downloads.  The Chapter 8 !les include a pdf of the Sibelius drum map and also the GM percussion 
map (for entering notes via MIDI keyboard)

Homework

Homework is to practice creating drum patterns in different styles.

Open the Drum Part Examples document and replicate everything on the page, using the instructions 
above as a guide.
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